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USING PAINT, PAINT.NET AND PHOTOSHOP TO WORK WITH 
IMAGES.  
 
First a little information about some programs for image manipulation: 
 
PAINT (Start: All Programs: Accessories: Paint) is a very simple application bundled with 
Windows XP. It has few facilities, but is still usable for one or two things.  
 
PAINT.NET: There is a much more sophisticated version called PAINT.net, which is free, and is 
available from http://www.getpaint.net/ if you want it for your own machine.  
 
GIMP is a general-purpose image manipulation package that runs on a wide variety of 
computers.  GIMP stands for GNU Image Manipulation Program (and Gnu stands for GNU is 
Not Unix: for further details see http://www.gnu.org/home.shtml). GIMP is perhaps not the 
easiest piece of software to learn: there are simpler tools for generating digital images. GIMP is 
free, and is available on the net (note: install a stable version!) 
 
PHOTOSHOP (Start → Programs → Adobe Design Premium CS5 → Adobe Photoshop 
CS5) is probably the favourite image manipulation package: it’s not free, and is marketed by 
Adobe. It is the software of choice, for this area: but it actually offers very few facilities not 
available in GIMP (and, in deed, Paint.net will often provide all that you actually need!)  
 
(Note for printed version only: this is in black & white. The version on WEBCT is in colour.) 
 

How to use this lab session: 
If you have never used any image manipulation tools (or only iPhoto or Picasa), I suggest you 
look briefly at Paint, then take a little longer over Paint.net, then look at Photoshop. 
 
If you are familiar with the use of simple image manipulation tools like Paint and paint.net, then 
jump straight to Photoshop. But if you find it hard going, go back and look at Paint.net. 
 
If you spend your time using GIMP or Photoshop already, and are actually an electronic artist 
exhibiting in galleries, then use GIMP or Photoshop and write me an advanced lab sheet.   
 
If you are somewhere between the last two, then try out Photoshop and perhaps GIMP as well.  
 
There is a separate lab sheet about GIMP (which is optional; but could be useful if you want to do 
image manipulation on your own machine and can’t afford PhotoShop!).  
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PAINT 
The simplest tool is Paint If you have never actually used this program, it might be an idea to try 
it first. (Even if you have, it’s probably useful to use it again just to refresh your memory – and 
this will take about 5 minutes if you are used to Paint.) 
 

The Toolbox in paint 

 
Paint allows the user to  

• Select areas of the image (and these may be rectangular or free-form areas) 
• To draw or erase on the image 
• To draw particular shapes 

And to choose a colour, and then fill that area/shape/drawn line with colour. The Text tool can 
be used (for example) to annotate images. 
 
 
Here’s some suggestions as to what you might do.  
 
Open a photograph using  File: open. (If you have no photographs in your 
filestore, you can get some from WEBCT. Look in the DGM901 WEBCT under 
either resources or materials: GIMP. Using the Web pages in there, right-click 
on a link, and save it somewhere in your filestore).  Now add some annotation 
to this image. Try drawing a rectangle with PAINT. Note that when you select a 
rectangle (or other shape for drawing), a submenu opens below the toolbox. The top one selects 
drawing the edges only, the middle one selects drawing a fillable rectangle (with the outer 
edges), and the bottom one draws a filled shape. You can change the colour of these using the 
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colour from the bottom palette, or if you would like to be marginally more adventurous, using 
the  Colors: Edit Colors panel (to get the full selection colours use the “Define Custom Colors” 
Button). 
 
You can draw straight lines by selecting an appropriate pen, and dragging the mouse. Holding 
down shift at the same time makes the line drawn be either vertical, horizontal, or at 45 degrees.  
 
Try to create a professional looking drawing. Once you start adding a number of different 
entities, it starts to get difficult: in general, Paint is not really sufficiently sophisticated for many 
purposes (but nonetheless, it can be useful for doing something quickly, and it is very 
straightforward, as well as free. But it lacks important facilities, like cropping an image to a 
particular size. 
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PAINT.NET. 
Paint.net is a much more powerful piece of software than Paint. In particular, it has layers, 
allowing an image to be built up layer by layer. There is a really excellent interactive tutorial on 
the web about Paint.net, originally at http://eulogy-dignity.deviantart.com/art/Paint-NET-
Interactive-Guide-71790584, and I have made it available locally at 
http://www.cs.stir.ac.uk/~lss/DGM901/Paint.Net/BeginnerGuide2.0.html 
 
There is also the more usual type of tutorial on it at 
http://www.eecs.wsu.edu/paint.net/doc/2.6/Help/en/index.html 
 
For reference, here is the toolbox in Paint.net 

Rectangle select

Lasso Select

Ellipse select

Magic wand

Paint Bucket

Paint brush

Pencil

Clone Stamp

Text

Rectangle

Ellipse

Move selected pixels

Move selection

Zoom

Pan

Gradient

Eraser

Color Picker

ReColor

Line/Curve

Rounded Rectangle

Freeform Shape
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PHOTOSHOP 
This part of the lab sheet aims 

• To give you some practical experience of some of the main features of Adobe’s 
Photoshop, which is the leading software package for pixelmap image creation 
and manipulation. 

• To take a look at a few useful graphics creation techniques, suitable for 
multimedia graphics. 

• To help your understanding of colour and colour models. 
• To practically illustrate some of the graphics material covered in lectures so far 

and that you will encounter in future graphics lectures, particularly different 
graphics file formats. 
 

Firstly we’ll need to have some colours set, before taking a look at some of 
Photoshop’s main features.  Set the foreground and background colours: 
 
⇒  Click on the foreground colour in the toolbox.  A colour picker box should 
appear. 
 
Click to select desired colour    New and current colour 
            
         
 
 
 
 
 
         
 
 
 
 
 
 
 
 
 
 
 
 
 
 

different brightnesses 
and saturations of the 
same hue displayed in 
main box 
(as hue currently 
selected) 

values for 
current colour 
in HSB colour 
model 
 

currently-
selected 
hue 

restriction 
to web-safe 
colours 
or not 

hex value of colour 
(e.g. for use in HTML) 

...and in the 
Lab, 
RGB, 
CMYK models 
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This is an excellent opportunity to make sure you understand how the various colour models 
work, so play around with the colour picker until you’ve got the idea of them. In particular, 
follow these suggestions: 
 
⇒  Click on the check box for web-safe colours (if it wasn’t already selected). Note the 
difference in the range of colours available. 
 
You probably have lots of colours of the same 
hue visible at the moment. One of the colour 
models supported by this colour picker is the 
HSB model (one of the variants of HSV you 
saw in lectures). 
pick a colour you like for the foreground! 

 
⇒  Now also select a colour for the 
background. Pick a colour that strongly 
contrasts with your chosen foreground colour. 

 
So far we have not had an image to apply 
our colours to.  Before we do that, on the 
right is a list of what each icon in the 
toolbar does. Note that most of these icons 
can change to further icons that can be 
displayed by right-clicking on them (see 
next page 
 
 
Let’s create an image: 
 
⇒  Open up a new image (File →  New), of 
whatever size you like (400 by 400 pixels 
is a useful size – you may need to change 
the dimensions to pixels), select 
Background colour for Background 
Contents and ensure the image is in RGB 
Color mode with a resolution of 72 pixels 
per inch. 
 
 
 
Shapes: select then edit 
 
There are various ways of selecting areas 
in Photoshop. You can use one of the tools 
to define an area, or to select something already created. The marquee tool (top left of 
the toolbox) is one of these, that can select simple rectangles and ovals. 
 
⇒  Use the marquee tool (top left of the toolbox) to select a nice big rectangle or oval 
in your image. 
 

Marquee tools
Move tool

Lasso tools

Quick selection/magic wand tool tool

Crop tool (Slice tool)

Eyedropper/ruler/note  tool

Spot healing brush/patch, red-eye tool

Brush/pencil/color replacement tools
Clone pattern/patternstamp tool

History/art history brush tool

Eraser/Magic eraser tool

Gradient/paintbucket tool

Blur/sharpen/smudge tools

Dodge/Burn/Sponge tools

Pen/anchor point tools

Horizontal/vertical type tool

Path selection/Direct selection tool

Rectangle/ellipse etc tool

3D object rotate/pan/roll tool

3D camera tools
Hand/rotate view tools

Zoom tool

Foreground/background colour tool

Edit in quick mask mode.
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You should see a moving marquee outlining your shape. Now let’s do something with 
that shape, say by using the gradient tools (halfway down the toolbox). 
 
⇒  Double click on the gradient tool, to bring up the gradient settings toolbar (below 
the menu toolbar).  Make sure the mode is normal, the opacity is 100. 
 
⇒  Select your choice of gradient tool from the 
selection of icons on the toolbar (see right).Then 
click and drag in your selected shape to perform 
the gradient fill. 
 
Don’t like it? Try several more times, with different 
gradient fills if you like, until you get one you like.  
You can also try changing the settings, such as mode 
and opacity. 
 
It’s also worth mentioning there are other ways to 
select. For example, when you have selected one 
shape, you can also select everything but that shape. To create a really bizarre image: 
 
⇒ Choose new contrasting foreground/background colours. Go up to the menus, Select → 
Inverse. Now do another gradient fill on everything but your 
original shape. 

Layers 
 
Photoshop lets you organize your work on layers. With 
the use of transparency, it makes it easy to combine 
images in different ways to form composite images. You 
can see the layers palette at the bottom right of your 
screen. If you don’t have it, click on Window →  Layers. 
 
What you’ve done so far should be in a background layer 
and you should be able to see a block in the layers palette, 
representing your background, with a tiny thumbnail of 
your image so far on it. Let’s create another layer. We’ll 
add some text to the picture. 
Text 
 
⇒  Select the Text tool from the toolbox. 
 
You should get a different cursor, and then clicking on the image allows you to select the 
position of entry for the text. Now you should get a toolbar with various options to play 
around with the text. 
 

 
 
⇒  Type in some text, and try out the various options for text (see below for hints).  
 
Select (highlight) the text you type, then font choices will show up immediately as you 
choose them. Try a contrasting colour for your text. Try different fonts at different sizes. 
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Also, try out some text options. For this, a good font to choose is Times. You’ll also want 
to enlarge the image quite a lot so that you can see what effect the aliasing has on the 
image. To enlarge the image, press CTRL and + together. Repeat several times (and use 
the scrollbars) to get a good size magnification. (CTRL and – will zoom out again). How 
do smooth/strong/crisp/sharp and none compare? 
 
⇒ Now try out some different text. Type in “YAWN!” 
and highlight it. Try clicking on the icon at the far right 
of the text toolbar: you should see the panel on the 
right. 

 
Change the value in the AV panel to -100: you 
should be able to see the distance between letters 
shrink. Try out the other options in this panel as 
well. 
 

Saving Your Images 
 
Photoshop uses its own native file format called 
PSD for its image files.  These files are usually 
very large, but they retain all the information you need to continue editing your image 
at a later time, such as any separate layers that you are using.  It is recommended that 
you only store your images in PSD format if you will need to edit them again. (On the 
other hand, if you do need to edit them again, then you must store them in this format). 
Otherwise save them in a format suitable for the particular image and its intended use, 
such as GIF or JPG. 
 
⇒ To save your image in a suitable format, select File: Save as Copy… and select the file format 
that you want, such as GIF.  Navigate to somewhere suitable in your file space, enter a file name 
and click Save.  Depending on the format you have selected you may get a number of dialog 
boxes appearing (such as “Flatten layers?”).  Clicking Yes and accepting any default values is 
usually suitable here. 

Having tried out a very few effects in Photoshop, let’s try out some more sophisticated 
features that can produce graphics that you might just find useful... 
 
Graphics Example 1: Little Ball Icons 
 
This example looks at how to create little ball icons that you could use to, say, highlight 
entries in lists of things on a web page. 

Here’s an example, enlarged so that you can see it:  
 
 
⇒ Open a new image, about 40 x 40 would be a good size, with a 
white background. (Make sure that the RGB colour model is 
being used when you initialise it.)   
 
⇒ Now magnify it to a nice, enormous size (it makes doing the 
drawing bits a lot easier; use Ctrl-+; note that Photoshop seems to 
crash at certain sizes when drawing the ball!) 
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⇒ With the Elliptical marquee tool, select a circle-sized area on your image (hold down 
the shift key while dragging from top left to bottom right to get a perfect, large circle): 
 
 
⇒ Now select as a foreground colour whatever colour you want the ball icon to be, say a 
nice medium blue. 
 
⇒ Select the paint bucket tool  (you may need to right-click on the gradient tool to select 
the paint bucket). Then click in the circle to fill it. 
 
⇒ Now go to the menu and select Filter → Render → Lighting Effects. 
 
⇒ Of the various styles available, select “Flashlight” and narrow 
the focus of the light by dragging in the preview box. Drag the 
centre of the light towards the upper left hand corner. Set the 
intensity to about 35, and the gloss to about 45. Click on Ok.  
You should now have something like: 
 
⇒ Now choose Select → Inverse from the menus.  
You should now see everything but the ball selected. This 
enables you to draw on everywhere but the ball itself. 
 
⇒ Select the brush tool (right-click alternative to pencil tool). Adjust the brush type to 
airbrush, and the brush size to 9 pixels (first two options in the Brush toolbar that 
appears below the main menu). Select the foreground colour 
grey. 
 
⇒ Now airbrush in a shadow behind the ball by clicking-and-
dragging. You should now have something like: 
 
Finally, add a little highlight to the ball: 
 
⇒ Do Select → Inverse to select the ball again, then still using the 
airbrush, but using a white colour, and with a pretty small brush 
(eg 4px), brush in a little highlight to the lightest spot on the upper 
left of the ball.  

 
Hopefully you now have a ball like: 
 
View it at the correct magnification. You can change the size of 
the ball to get an icon as small as you want. Save it in a file for 
now, in GIF format, as you did with your text image.  
 
But what if you want several balls of different colours? 
 
⇒ Go to Image → Adjustments → Hue/Saturation and use the sliders there to adjust the colour! 
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Free Form Fun! 
 
Now that you have a few Photoshop skills under your belt, let’s have some fun.  The 
instructions given here will assume that you have completed the practical session so far.  
You may need to refer back to the instructions above to remind yourself of how to do 
various things. 
 
What we will do is play with an existing photo (perhaps one acquired earlier with a 
digital camera or scanner.) You can use your own, find one on the web, or there are 
suitable photos accessible via a web browser at: 
 
http://www.cs.stir.ac.uk/~lss/DGM901/Photos/photos.html 
 
In Photoshop, close any image windows you have finished with and then: 
 
⇒  Create a new image of a suitable size (say 400 by 400 pixels), in RGB Color mode and using 

Background Color. 

 
Select foreground and background colours and fill the image, using a gradient tool of 

your choice. 
 
Copy one of the photos (from the folder or webspace listed above) that you like to your 

own file space and open it in Photoshop via File:Open.  
 
A new image window will appear in Photoshop showing the photo.  We will first resize 
the photo, and then incorporate it into your background image, as follows. 
  
You may need to resize the photo by selecting Image→Image size… so that it will fit 

onto your background. 
 
Select the Move tool from the Toolbox, then click-and-drag the photo from its window 

onto your “background” window (you might need to select a suitable window 
arrangement from Window→Arrange so you can see both images at once). 

 
This has put a copy of the photo on a new layer in your image.  Having it on a separate 
layer means you can easily manipulate the photo independently of the background.  
Move the photo around until it is positioned where you would like it. 
 
Add a title above the photo using the Text tool.  Add any effects to the title that you 

would like using Layer→Layer Style e.g. Drop Shadow. 
 
Now we’ll have some fun with the photo. First we will adjust the brightness, contrast 
and colour balance of the photo.  Then we’ll try out the various filters that Photoshop 
provides.  And try different blends of the photo with the background.  Make use of the 
online help to find out about the filters and blends that are available. 
 
Select the layer containing the photo in the Layers tab. 
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To adjust brightness and contrast, select Image→ Adjustments→ Brightness/Contrast…  
Make sure Preview is selected, then move the triangular markers to adjust the 
brightness and contrast.  Click OK when you are satisfied. 

 
Now adjust the colour balance by selecting Image→Adjustments→Color Balance… and 

adjusting the different colour channels in the same way as brightness/contrast. 
 
Now try out some of the different blends and filters. Blends specify how the pixels of the 
current layer are combined with those of layers beneath it.  Your photo layer should be 
in Normal mode (as shown in the Layers window). 
 
Click the dropdown arrow next to “Normal” on the Layers window and try some of the 

different blending options.  Return to “Normal” mode before carrying on. 
 
Filters apply various mathematical transformations to the pixels in a layer.  This can take 
quite a long time, so do not be surprised if you have to wait to see the results.  But let’s 
try some anyway. 
 
Select any of the options from Filter and see what happens.  Usually you will get a 

preview window before it is applied to the image itself (use Edit->Undo immediately if 
you need to reverse the filter once applied).  
 

Try Filter→Distort→Wave.  Itʼs particularly wild! 
 

Photoshopping 
 
Another capability that Photoshop has is for adjusting images subtly: sometimes known as 
photoshopping! 
 
Look at the image of Lencois in http://www.cs.stir.ac.uk/~lss/DGM901/Photos/photos.html 
 
Near the top, there is part of the helicopter from which the image was (I believe) taken. It would 
be a better image if this are was simply sky … 
You could simply crop the image. But you can also subtly 
change the image. Look at the Clone Stamp tool. This 
allows you to copy little pieces of an image smoothly to 
somewhere else in the image: in this case we can replace the 
dark parts of the image with pieces of sky copied from 
elsewhere.  
 
Select clone stamp. Now control-click somewhere in the 
photo. You will see a selection of areas that might be 
cloned, and be given the option of size and hardness. Then 
if you alt-click somewhere in the image, this area will be 
copied. And then you can paste it to over-write and area of 
the image. Try it: you may never believe another 
photograph again! 
 
(Lab sheet by LSS, BPG, DEC and others: © 2011) 
 


